Website issues

The place to discuss the Register itself
Post Reply
User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Website issues

Post by Alan » Mon Jun 08, 2009 7:06 pm

The website will be offline for periods of time this evening. :mod:

I am performing some security upgrades to the base software. This should stop the spambots that have made an appearance recently.

Sorry to be a pain but it is vital to maintain the long term security integrity of the site.

Alan.

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: WEBSITE OFFLINE

Post by Alan » Mon Jun 08, 2009 8:29 pm

OK all done.

If I did it right, non of you should see any differences. If you find any problems post it up in the 'Speak Easy'

Cheers,
Alan.

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: WEBSITE OFFLINE

Post by Alan » Tue Oct 13, 2009 12:48 am

I have received notification from the hosting company that the site will be offline while they move the servers to an new location. It will occur over the next few days and will mean the site will be unavailable for up to 3 hours.

After the move the site should function as normal.

Alan.

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: WEBSITE OFFLINE

Post by Alan » Mon Nov 23, 2009 1:34 am

I finished another major update of the server software about 5 mins ago. If you were having trouble getting access, my apologies but these updates mean the site is secure and protects you and all the information I have. :good:

Alan.

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: Website issues

Post by Alan » Mon Dec 07, 2009 2:03 am

After the security upgrade it has become apparent that there are a few 'issues' with the forum style that we use. The current software version includes some major changes to the way the system negotiates with the database.

What this means is that there are problems with the way the information you currently see on screen is arranged when you make a submission. That means the searches will return strange results and things like 'polls' won't function correctly, returning an error. The basic function of the forum should remain unaffected, so posting messages and sending PM's will continue as normal.

I've had a chat with the original author of the style we use and he expects to have a fully tested upgrade available in mid Jan if not before.

Alan.

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: Website issues

Post by Alan » Mon Nov 08, 2010 10:02 pm

Our webhost has informed me of a server upgrade on the 11th Nov 2010. This may (probably will) result in the website being unavailable for a short period while the upgrades are fitted and applied.

Alan.

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: Website issues

Post by Alan » Thu Nov 11, 2010 10:20 pm

The upgrade is currently taking place, the site has been a little quirky over the last few hours. This is normal whilst the work is done.

All should be normal by tomorrow.

Alan.

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: Website issues

Post by Alan » Sun Dec 26, 2010 6:11 pm

New security updates applied and working.

If you find any problems with the site, please let me know ASAP :good:

Alan.

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: Website issues

Post by Alan » Thu Mar 03, 2011 12:14 pm

Some of you may have noticed the site was a bit slow in recent days, I have traced the problem to the database system.
Its now repaired so normal function should be restored. :good:

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: Website issues

Post by Alan » Thu Jul 14, 2011 6:46 pm

New security updates applied and working.

As usual, If you find any problems with the site, please let me know ASAP :good:

Alan.

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: Website issues

Post by Alan » Mon Jan 16, 2012 11:47 am

The site will be offline for short periods later this evening. I will be installing a security update.

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: Website issues

Post by Alan » Tue Jan 17, 2012 12:03 am

Updates all done and site reconfigured.
As usual, let me know if you find any errors :good:

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: Website issues

Post by Alan » Tue Feb 07, 2012 11:27 pm

In the ongoing, continuous battle with spammers, I have now modified part of the sites php coding.

This is a completely 'home brew' coding hack by myself and as such means its completely untested for side effects.

I am extremely confident that it wont affect anything in the normal running of the site so users should see no effect whatsoever

BUT

As nothing is guaranteed, if you do encounter anything unusual then let me know ASAP by replying here.

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: Website issues

Post by Alan » Tue Oct 16, 2012 8:56 pm

Alan wrote:The site will be offline for short periods later this evening. I will be installing a security update.
This again :good:

User avatar
Alan
Site Owner
Posts: 1789
Joined: Sun Mar 30, 2008 6:30 pm
Location: Shropshire, UK.
Contact:

Re: Website issues

Post by Alan » Tue Oct 16, 2012 8:57 pm

Alan wrote:Updates all done and site reconfigured.
As usual, let me know if you find any errors :good:

And this again :grin:

Post Reply