Clutch

Technical questions and answers
Post Reply
Andy4033
Posts: 44
Joined: Wed Feb 19, 2014 4:08 pm

Clutch

Post by Andy4033 » Mon Jul 14, 2014 8:09 am

Hi

So here are the parts (or what's left) after removal. But we are still having difficulty trying (recognise) sort out a replacement fork, any suggestions would be a help.
Thanks Andy
Attachments
1404914408522.jpg
1404914408522.jpg (19.73 KiB) Viewed 3137 times
1404915041577.jpg
1404915041577.jpg (17.79 KiB) Viewed 3137 times
1404915002770.jpg
1404915002770.jpg (19.46 KiB) Viewed 3137 times

User avatar
kev
Technical Expert
Posts: 1246
Joined: Tue Apr 01, 2008 8:58 pm
Location: west mids

Re: Clutch

Post by kev » Mon Jul 14, 2014 9:55 pm

Wots up with the fork there should be a small spring on there to hold the thrust bearing but looks ok to me

User avatar
cheiftain
Technical Expert
Posts: 1980
Joined: Wed Apr 02, 2008 11:20 am
Location: Cockfield, Suffolk. Near Magrathea

Re: Clutch

Post by cheiftain » Wed Jul 16, 2014 11:29 pm

look to me like someone's been riding the clutch, or didn't setup the slave rod clearance correctly. :shock:
The journey isn't about departing in a well preserved body - but rather to skid in sideways - totally worn out - shouting HOLY SHIT WHAT A RIDE!!!!

Be More like a Dog, If you can't, Eat it, Play with it, Chase it, or Bark at it, Just Piss on it and walk away.

Andy4033
Posts: 44
Joined: Wed Feb 19, 2014 4:08 pm

Re: Clutch

Post by Andy4033 » Fri Jul 18, 2014 8:45 am

Hi
Thanks but Ahmed cant find a new fork because he don't recognise it as its not standard and the hydrolic was never used in India.
and the latter as to the slave rod as it was missing part of the rubber when i removed it and the internal spring also a part unrecgnised so now we wait fo replacement parts.

Andy

User avatar
kev
Technical Expert
Posts: 1246
Joined: Tue Apr 01, 2008 8:58 pm
Location: west mids

Re: Clutch

Post by kev » Fri Jul 18, 2014 9:01 am

Looks like all the India ones had the smaller fork due to being cable clutch ,wots up with the fork .

Andy4033
Posts: 44
Joined: Wed Feb 19, 2014 4:08 pm

Re: Clutch

Post by Andy4033 » Fri Jul 18, 2014 6:40 pm

Nothing wrong with the fork just wanted to replace along with all the other moving parts ... GOOD NEWS my clutch slave cylinder kit turned up today and it Fits nice and tight will post all the details and part no as soon as we know it works for Alan to put in the parst list.

Post Reply